aboutsummaryrefslogtreecommitdiffstats
path: root/src/qml/CMakeLists.txt
diff options
context:
space:
mode:
authorFriedemann Kleint <Friedemann.Kleint@qt.io>2023-02-03 09:44:06 +0100
committerFriedemann Kleint <Friedemann.Kleint@qt.io>2023-02-13 21:20:42 +0100
commit504480194603d1ce3370da9ebbb6e6b9298e6a5e (patch)
tree24cd2aec9552657f455f8677e28a64f6ac446c2d /src/qml/CMakeLists.txt
parent1e844a092392e435b2cade93a909020ce299003e (diff)
QtQml: Add exclusions for CMake Unity (Jumbo) builds
Pick-to: 6.5 Task-number: QTBUG-109394 Change-Id: Ie0eba7bd81cb5e493aeb9be0693dfd2076b3fa7d Reviewed-by: Fabian Kosmale <fabian.kosmale@qt.io>
Diffstat (limited to 'src/qml/CMakeLists.txt')
-rw-r--r--src/qml/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/qml/CMakeLists.txt b/src/qml/CMakeLists.txt
index 1b00d685b6..815f9d26a7 100644
--- a/src/qml/CMakeLists.txt
+++ b/src/qml/CMakeLists.txt
@@ -426,6 +426,10 @@ qt_internal_add_qml_module(Qml
qt_update_ignore_pch_source(Qml "compat/removed_api.cpp")
+set_source_files_properties(compat/removed_api.cpp
+ jsruntime/qv4mathobject.cpp # math.h issues on Windows
+ PROPERTIES SKIP_UNITY_BUILD_INCLUSION ON)
+
qt_internal_add_qml_module(QmlMeta
URI "QtQml"
VERSION "${PROJECT_VERSION}"