aboutsummaryrefslogtreecommitdiffstats
path: root/src/qml/CMakeLists.txt
diff options
context:
space:
mode:
authorUlf Hermann <ulf.hermann@qt.io>2024-03-25 14:13:50 +0100
committerUlf Hermann <ulf.hermann@qt.io>2024-04-03 20:37:18 +0200
commit6314d305ee0d9064ca848980ef2dab1793c191b8 (patch)
tree9b0b471a41a3171e7938c0e99842aa12404105e4 /src/qml/CMakeLists.txt
parentaa2e2333376cefd1c7b8c3931097eb6dd4b96dd9 (diff)
Generate qmldir files for extra directories with QML files
Those qmldir files contain only a prefer directive for the canonical resource location of the module. This way, any time another component from the implicit import is requested, it will not be located in the extra directory (where it probably doesn't exist), but instead in the canonical location. Since people may have manually written qmldir files with different content in those places, or worse, relied on the other components to be inaccessible, we need a new policy to opt into this. Fixes: QTBUG-111763 Change-Id: If236feb7dd7c8d704b813ea56482ff758799d0a7 Reviewed-by: Fabian Kosmale <fabian.kosmale@qt.io>
Diffstat (limited to 'src/qml/CMakeLists.txt')
-rw-r--r--src/qml/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/src/qml/CMakeLists.txt b/src/qml/CMakeLists.txt
index cdd6017c63..fa672d3d6c 100644
--- a/src/qml/CMakeLists.txt
+++ b/src/qml/CMakeLists.txt
@@ -501,8 +501,9 @@ qt_internal_add_qml_module(Qml
"${INSTALL_CMAKE_NAMESPACE}QmlFindQmlscInternal.cmake"
${extra_cmake_includes}
GENERATE_CPP_EXPORTS
- POLICIES
+ POLICIES
QTP0001
+ QTP0004
)
_qt_internal_add_qml_deploy_info_finalizer(Qml)