aboutsummaryrefslogtreecommitdiffstats
path: root/src/qml/CMakeLists.txt
diff options
context:
space:
mode:
authorMarc Mutz <marc.mutz@qt.io>2023-07-20 21:39:15 +0200
committerMarc Mutz <marc.mutz@qt.io>2023-07-21 10:27:58 +0200
commit7e587fb00d371d15980e3cd70d40ed289f18799a (patch)
tree87709bfe96250402fe0918150791e8ccc3597e89 /src/qml/CMakeLists.txt
parent56e244b2e4743a1081f8af310323aad4a5ba5b6e (diff)
QtQml: unbreak unity-build-batch-size 100000
Exclude TUs that cause problems in a build where all of QtQml's .cpp files end up in a single unity_0_cxx.cxx. This should ensure that the build will forthwith not fail because someone added a new .cpp file in the "wrong" position. Of course, this is just a snapshot, with my configuration: Clang 15, Ubuntu 20.04, -developer-build, C++23, -sctp, libc++, ... Task-number: QTBUG-115140 Pick-to: 6.6 6.5 Change-Id: If3cb7c17548710dca3b6111b33a4d3ca70417728 Reviewed-by: Volker Hilsheimer <volker.hilsheimer@qt.io>
Diffstat (limited to 'src/qml/CMakeLists.txt')
-rw-r--r--src/qml/CMakeLists.txt25
1 files changed, 25 insertions, 0 deletions
diff --git a/src/qml/CMakeLists.txt b/src/qml/CMakeLists.txt
index a5a4c408f9..cd35596dbc 100644
--- a/src/qml/CMakeLists.txt
+++ b/src/qml/CMakeLists.txt
@@ -363,6 +363,31 @@ qt_internal_add_qml_module(Qml
qmltc/supportlibrary/qqmlcpponassignment_p.h
qmltc/supportlibrary/qqmlcpponassignment.cpp
qmltc/supportlibrary/qqmlcpptypehelpers_p.h
+ NO_UNITY_BUILD_SOURCES
+ jsapi/qjsvalue.cpp # \.
+ jsruntime/qv4engine.cpp # > WTF::String vs. QV4::String, dto. Object
+ jsruntime/qv4jsonobject.cpp # |
+ jsruntime/qv4object.cpp # |
+ jsruntime/qv4proxy.cpp # |
+ jsruntime/qv4qmlcontext.cpp # |
+ jsruntime/qv4reflect.cpp # |
+ jsruntime/qv4regexpobject.cpp # |
+ jsruntime/qv4script.cpp # | ((also?) Function)
+ jsruntime/qv4string.cpp # |
+ jsruntime/qv4stringobject.cpp # | ((also?) Property)
+ jsruntime/qv4typedarray.cpp # |
+ jsruntime/qv4urlobject.cpp # | ((also?) Property)
+ qml/qqmlbuiltinfunctions.cpp # |
+ qml/qqmllistwrapper.cpp # |
+ qml/qqmllocale.cpp # |
+ qml/qqmltypecompiler.cpp # | (also Binding)
+ qml/qqmltypewrapper.cpp # |
+ qml/qqmlxmlhttprequest.cpp # / (also Document)
+ jsruntime/qv4managed.cpp # QQmlJS::Managed vs. QV4::Managed
+ jsruntime/qv4module.cpp # QV4::Compiler::Module vs. QV4::Module
+ jsruntime/qv4vme_moth.cpp # 'MOTH_BEGIN_INSTR' macro redefined (from qv4instr_moth.cpp)
+ qml/qqmltypecompiler.cpp # 'COMPILE_EXCEPTION' macro redefined (from qqmlirbuilder.cpp)
+ qml/qqmlmetamoduleregistration.cpp # declares 'registration' clashing with qml_* files
DEFINES
BUILDING_QT__
ENABLE_ASSEMBLER_WX_EXCLUSIVE=1