aboutsummaryrefslogtreecommitdiffstats
path: root/src/qml/CMakeLists.txt
diff options
context:
space:
mode:
authorSami Shalayel <sami.shalayel@qt.io>2023-07-05 16:53:09 +0200
committerSami Shalayel <sami.shalayel@qt.io>2023-07-21 17:22:02 +0200
commit8d3e116068fc3432497f229e10f5b18d183c8f54 (patch)
treea40038245f45465dc7bdd6689d055dfb56f706d7 /src/qml/CMakeLists.txt
parent6d64967f85efb8f5e79109dd8e60e92a74308e82 (diff)
QQmlSignalNames: Add implementation for signal name manipulations
Add a set of static helper methods in src/qml/common/qqmlsignalnames{_p.h,.cpp} to do signal name manipulations (from signal to signal handler name and back, from property to property changed signal to property changed handler and back). Add tests in tst_qml_common for the helper methods. ToDo in following commit: replace all implementations of signal name manipulations out there with the helpers introduced in this commit. Change-Id: I8e606375839d9eda673da121a60484c5d211f4a0 Reviewed-by: Fabian Kosmale <fabian.kosmale@qt.io>
Diffstat (limited to 'src/qml/CMakeLists.txt')
-rw-r--r--src/qml/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/qml/CMakeLists.txt b/src/qml/CMakeLists.txt
index cd35596dbc..c907f2b17b 100644
--- a/src/qml/CMakeLists.txt
+++ b/src/qml/CMakeLists.txt
@@ -128,6 +128,7 @@ qt_internal_add_qml_module(Qml
common/qv4staticvalue_p.h
common/qv4stringtoarrayindex_p.h
common/qqmltranslation.cpp common/qqmltranslation_p.h
+ common/qqmlsignalnames_p.h common/qqmlsignalnames.cpp
compat/removed_api.cpp
compiler/qqmlirbuilder.cpp compiler/qqmlirbuilder_p.h
compiler/qv4bytecodegenerator.cpp compiler/qv4bytecodegenerator_p.h