aboutsummaryrefslogtreecommitdiffstats
path: root/src/qml/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexey Edelev <alexey.edelev@qt.io>2024-03-06 15:28:41 +0100
committerAlexey Edelev <alexey.edelev@qt.io>2024-03-07 18:27:08 +0100
commita3ff421d248339c187a20df8a7a24932bb28bbc4 (patch)
treef10576dced76d886419bae19aedca0f4035efd15 /src/qml/CMakeLists.txt
parentbad5a7ac1fe3ec39c6c9a0111f1514177a69315e (diff)
Consider Qt6::Qml compile definitions when manually running moc
Consider compile definitions of Qt6::Qml target, but not only include directories when manually running moc. Fixes: QTBUG-104898 Change-Id: I6fd15a346b7cb4b02a68ab2d034aac14d711d00e Reviewed-by: Jari Helaakoski <jari.helaakoski@qt.io> Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io> Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org>
Diffstat (limited to 'src/qml/CMakeLists.txt')
-rw-r--r--src/qml/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/qml/CMakeLists.txt b/src/qml/CMakeLists.txt
index 0b9dd7c68c..9cbc8e10a5 100644
--- a/src/qml/CMakeLists.txt
+++ b/src/qml/CMakeLists.txt
@@ -46,7 +46,7 @@ qt_manual_moc(extra_builtins_moc_files
qml/qqmlcomponent.h
qml/qqmlcomponentattached_p.h
qml/qqmlscriptstring.h
- INCLUDE_DIRECTORY_TARGETS Qt::Qml
+ TARGETS Qt6::Qml
)
# The moc files are included directly by qqmlcomponent.cpp and qqmlscriptstring.cpp