aboutsummaryrefslogtreecommitdiffstats
path: root/src/qml/CMakeLists.txt
diff options
context:
space:
mode:
authorMarc Mutz <marc.mutz@qt.io>2022-05-09 15:40:41 +0200
committerMarc Mutz <marc.mutz@qt.io>2022-05-09 23:42:21 +0200
commitc2b1aad7918d23f3094525c0a57ae4c9fd88b81e (patch)
treeea89ee84f7e852621289c92a3db5d7ff6f5437d1 /src/qml/CMakeLists.txt
parentd432e5621a0a163ea5609229ef94f83235de4050 (diff)
Add a TU for QV4::Debugging::Debugger to de-inline dtor & includemocs
Destructors of polymorphic classes should be out-of-line. Header moc files should be included into the implementation files. Both need a TU, so add one. Task-number: QTBUG-102948 Task-number: QTBUG-45582 Change-Id: Ia596ec1cab1e4c1f91e42cf217a7df7cbd0d91ad Reviewed-by: Ulf Hermann <ulf.hermann@qt.io>
Diffstat (limited to 'src/qml/CMakeLists.txt')
-rw-r--r--src/qml/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/qml/CMakeLists.txt b/src/qml/CMakeLists.txt
index 18522c5eb3..0191be67da 100644
--- a/src/qml/CMakeLists.txt
+++ b/src/qml/CMakeLists.txt
@@ -158,7 +158,7 @@ qt_internal_add_qml_module(Qml
jsruntime/qv4context.cpp jsruntime/qv4context_p.h
jsruntime/qv4dataview.cpp jsruntime/qv4dataview_p.h
jsruntime/qv4dateobject.cpp jsruntime/qv4dateobject_p.h
- jsruntime/qv4debugging_p.h
+ jsruntime/qv4debugging.cpp jsruntime/qv4debugging_p.h
jsruntime/qv4domerrors.cpp jsruntime/qv4domerrors_p.h
jsruntime/qv4engine.cpp jsruntime/qv4engine_p.h
jsruntime/qv4enginebase_p.h