aboutsummaryrefslogtreecommitdiffstats
path: root/src/qml/CMakeLists.txt
diff options
context:
space:
mode:
authorUlf Hermann <ulf.hermann@qt.io>2022-05-20 15:26:47 +0200
committerUlf Hermann <ulf.hermann@qt.io>2022-05-24 15:44:16 +0200
commitdc77f7c71c532a1c51f7618765559937fd5d2eb3 (patch)
treef1d633a5033b0a4cc30c52aac9b3b0a5be05385d /src/qml/CMakeLists.txt
parent3d8702378ba7f8252862aac8d71995d61f4f2b69 (diff)
Replace synthetic AOT functions with property-to-property bindings
Those should be more efficient and make your feet attract fewer projectiles. Fixes: QTBUG-103588 Change-Id: I8b25b9edb1edf5e112dbcba5bba898646d29ae2b Reviewed-by: Fabian Kosmale <fabian.kosmale@qt.io>
Diffstat (limited to 'src/qml/CMakeLists.txt')
-rw-r--r--src/qml/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/qml/CMakeLists.txt b/src/qml/CMakeLists.txt
index af9beeb627..a10228f3bb 100644
--- a/src/qml/CMakeLists.txt
+++ b/src/qml/CMakeLists.txt
@@ -312,6 +312,7 @@ qt_internal_add_qml_module(Qml
qml/qqmlpropertydata_p.h
qml/qqmlpropertyindex_p.h
qml/qqmlpropertyresolver.cpp qml/qqmlpropertyresolver_p.h
+ qml/qqmlpropertytopropertybinding.cpp qml/qqmlpropertytopropertybinding_p.h
qml/qqmlpropertyvalidator.cpp qml/qqmlpropertyvalidator_p.h
qml/qqmlpropertyvalueinterceptor.cpp qml/qqmlpropertyvalueinterceptor_p.h
qml/qqmlfinalizer.cpp qml/qqmlfinalizer_p.h