aboutsummaryrefslogtreecommitdiffstats
path: root/src/qml/CMakeLists.txt
diff options
context:
space:
mode:
authorAndrei Golubev <andrei.golubev@qt.io>2021-02-16 12:52:41 +0100
committerAndrei Golubev <andrei.golubev@qt.io>2021-12-17 08:57:27 +0100
commite7ce5abf24f04d1b071343f07ca28b6a5d9ad4b9 (patch)
treed02bcd3d19a7a2900311d34b8275fa6e9d376d7f /src/qml/CMakeLists.txt
parent6f2a1487b723206da5b4f363a0c9ddb6d7333367 (diff)
Use qmltc compiler prototype as a fallback implementation
Task-number: QTBUG-91927 Task-number: QTBUG-96041 Task-number: QTBUG-84368 Pick-to: 6.3 Change-Id: I47320b5f3ed8efff6fb234778df5fae5be5b64f2 Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org> Reviewed-by: Fabian Kosmale <fabian.kosmale@qt.io>
Diffstat (limited to 'src/qml/CMakeLists.txt')
-rw-r--r--src/qml/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/qml/CMakeLists.txt b/src/qml/CMakeLists.txt
index 65667b865d..046e29fdcd 100644
--- a/src/qml/CMakeLists.txt
+++ b/src/qml/CMakeLists.txt
@@ -345,6 +345,10 @@ qt_internal_add_qml_module(Qml
types/qqmlconnections.cpp types/qqmlconnections_p.h
util/qqmlpropertymap.cpp util/qqmlpropertymap.h
qmltc/qqmltcobjectcreationhelper_p.h
+ qmltc/supportlibrary/qqmlcppbinding_p.h
+ qmltc/supportlibrary/qqmlcppbinding.cpp
+ qmltc/supportlibrary/qqmlcpponassignment_p.h
+ qmltc/supportlibrary/qqmlcpponassignment.cpp
DEFINES
BUILDING_QT__
ENABLE_ASSEMBLER_WX_EXCLUSIVE=1