aboutsummaryrefslogtreecommitdiffstats
path: root/src/qml/CMakeLists.txt
diff options
context:
space:
mode:
authorUlf Hermann <ulf.hermann@qt.io>2022-01-10 16:53:05 +0100
committerUlf Hermann <ulf.hermann@qt.io>2022-01-15 14:22:42 +0100
commitf73e294472906077556e13ca10df185300c2450f (patch)
treefece290b38c3d3d4b047b90692a296eabc345905 /src/qml/CMakeLists.txt
parent2715d67f53efc916f212022572fa639d7704b43c (diff)
Remove the qml_sequence_object feature flag
QML sequences are required for named lists of value types. The original reason for the introduction of this feature was the template code explosion caused by the way the sequence types were registered in Qt5. As we register them differently now, the code size overhead should be smaller. It makes very little sense to switch sequence types off these days. [ChangeLog][QtQml][Important Behavior Changes] The qml_sequence_object feature flag has been removed. Omitting sequences from the QML language does not make much sense now that we use them for lists of value types. The original reason to allow it was that the sequence support took up a lot of space in the binary. This is not the case anymore since 6.0. Change-Id: I2f1d43cdd29ba63853316b06113cb49ed30aa410 Reviewed-by: Joerg Bornemann <joerg.bornemann@qt.io> Reviewed-by: Fabian Kosmale <fabian.kosmale@qt.io>
Diffstat (limited to 'src/qml/CMakeLists.txt')
-rw-r--r--src/qml/CMakeLists.txt6
1 files changed, 1 insertions, 5 deletions
diff --git a/src/qml/CMakeLists.txt b/src/qml/CMakeLists.txt
index 1266b6ac1d..2fbf187978 100644
--- a/src/qml/CMakeLists.txt
+++ b/src/qml/CMakeLists.txt
@@ -223,6 +223,7 @@ qt_internal_add_qml_module(Qml
jsruntime/qv4value.cpp jsruntime/qv4value_p.h
jsruntime/qv4variantobject.cpp jsruntime/qv4variantobject_p.h
jsruntime/qv4vme_moth.cpp jsruntime/qv4vme_moth_p.h
+ jsruntime/qv4sequenceobject.cpp jsruntime/qv4sequenceobject_p.h
jsruntime/qv4vtable_p.h
memory/qv4heap_p.h
memory/qv4mm.cpp memory/qv4mm_p.h
@@ -537,11 +538,6 @@ qt_internal_extend_target(Qml CONDITION QT_FEATURE_qml_debug AND QT_FEATURE_tran
debugger/qqmldebugtranslationprotocol_p.h
)
-qt_internal_extend_target(Qml CONDITION QT_FEATURE_qml_sequence_object
- SOURCES
- jsruntime/qv4sequenceobject.cpp jsruntime/qv4sequenceobject_p.h
-)
-
qt_internal_extend_target(Qml CONDITION UNIX
SOURCES
jsruntime/qv4compilationunitmapper_unix.cpp