aboutsummaryrefslogtreecommitdiffstats
path: root/src/qmlxmllistmodel/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexey Edelev <alexey.edelev@qt.io>2021-06-29 15:27:51 +0200
committerAlexey Edelev <alexey.edelev@qt.io>2021-11-02 16:32:25 +0100
commit250d6269e9f60021d88a574d04941ab342afb632 (patch)
treeb2630f309c5e94384b739e15d8c6a69e2e137101 /src/qmlxmllistmodel/CMakeLists.txt
parent6b4d3613326b38bc05c813c449b31affd9c3795a (diff)
Migrate to autogenerated cpp exports
Replace the hardcoded cpp exports with a generated one where it's applicable. Task-number: QTBUG-90492 Change-Id: I4af021bf828e05c8d6f3f975befd3b6b2cf63462 Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'src/qmlxmllistmodel/CMakeLists.txt')
-rw-r--r--src/qmlxmllistmodel/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/qmlxmllistmodel/CMakeLists.txt b/src/qmlxmllistmodel/CMakeLists.txt
index 3a74462081..1938ed3158 100644
--- a/src/qmlxmllistmodel/CMakeLists.txt
+++ b/src/qmlxmllistmodel/CMakeLists.txt
@@ -17,6 +17,8 @@ qt_internal_add_qml_module(QmlXmlListModel
Qt::Qml
PRIVATE_MODULE_INTERFACE
Qt::CorePrivate
+ GENERATE_CPP_EXPORTS
+ GENERATE_PRIVATE_CPP_EXPORTS
)
qt_internal_add_docs(QmlXmlListModel