aboutsummaryrefslogtreecommitdiffstats
path: root/tests/auto/CMakeLists.txt
diff options
context:
space:
mode:
authorTatiana Borisova <tatiana.borisova@qt.io>2022-02-18 12:13:56 +0200
committerTatiana Borisova <tatiana.borisova@qt.io>2022-03-10 23:33:36 +0200
commit09cb6a4952d17925c8389216c16605eb68ab3418 (patch)
tree75f8fa8476689f6f82b5461e05acc99cb3c25545 /tests/auto/CMakeLists.txt
parenta1f067d809b45759f5783ac2c3a38cdc8139e8fc (diff)
Add several autotest cases to Minimal set for STATIC build
- It is not possible to build all autotests for STATIC build, because CI doesn't have enough resources. But it is possible to build a few tests on CI for INTEGRITY testing. Task-number: QTBUG-99123 Pick-to: 6.2 6.3 Change-Id: I698edb9cd0696dd55e1b82547cb57c34b993bb10 Reviewed-by: Ulf Hermann <ulf.hermann@qt.io> Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org> Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'tests/auto/CMakeLists.txt')
-rw-r--r--tests/auto/CMakeLists.txt7
1 files changed, 5 insertions, 2 deletions
diff --git a/tests/auto/CMakeLists.txt b/tests/auto/CMakeLists.txt
index 3ef1b6e735..0962fccb1b 100644
--- a/tests/auto/CMakeLists.txt
+++ b/tests/auto/CMakeLists.txt
@@ -1,13 +1,16 @@
add_subdirectory(cmake)
+if(TARGET Qt::Quick)
+ add_subdirectory(qml)
+ add_subdirectory(quick)
+endif()
+
# Limit set of tests to run for static Qt builds.
if(QT_BUILD_MINIMAL_STATIC_TESTS)
return()
endif()
if(TARGET Qt::Quick)
- add_subdirectory(qml)
- add_subdirectory(quick)
add_subdirectory(quicktest)
endif()
if(TARGET Qt::QuickTest)