aboutsummaryrefslogtreecommitdiffstats
path: root/tests/auto/CMakeLists.txt
diff options
context:
space:
mode:
authorFawzi Mohamed <fawzi.mohamed@qt.io>2021-12-13 03:41:19 +0100
committerFawzi Mohamed <fawzi.mohamed@qt.io>2021-12-21 12:25:41 +0100
commit25ac957f6da559333938430eec9cc341823e22cc (patch)
treef6dd1784fc93fbcd92b16a960616ea964676dbb2 /tests/auto/CMakeLists.txt
parent2eb0ad0150c23b128f877bc138085612b4f78d49 (diff)
qmlls: qml language server implementation
This is the initial commit, with just qmllint integration, but many of the tricky bits and the architecture are already there, see the description in qqmllanguageserver.cpp and qqmlcodemodel.cpp Pick-to: 6.3 Change-Id: Ie493fed02276f938fde641e8d91c67aed0514d1f Reviewed-by: Andrei Golubev <andrei.golubev@qt.io>
Diffstat (limited to 'tests/auto/CMakeLists.txt')
-rw-r--r--tests/auto/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/auto/CMakeLists.txt b/tests/auto/CMakeLists.txt
index 2476a8fe76..fa570a9ddc 100644
--- a/tests/auto/CMakeLists.txt
+++ b/tests/auto/CMakeLists.txt
@@ -25,6 +25,7 @@ if(TARGET Qt::QuickWidgets)
endif()
if(TARGET Qt::QmlDomPrivate)
add_subdirectory(qmldom)
+ add_subdirectory(qmlls)
endif()
if(TARGET Qt::QuickTemplates2)
add_subdirectory(quickcontrols2)