aboutsummaryrefslogtreecommitdiffstats
path: root/tests/auto/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2021-06-25 10:58:39 +0200
committerAlexandru Croitor <alexandru.croitor@qt.io>2021-08-06 17:25:12 +0200
commit39d8bef8dc3d2cf8a0c7bdb418e66fc8329dfc98 (patch)
treef56a71d39a4c457bfb95b2a2900965ab95836691 /tests/auto/CMakeLists.txt
parent272f9449ce505e753a5d8a9e3f9b942e3551a614 (diff)
CMake: Build minimal subset of tests in desktop static builds
For now we limit it to cmake auto tests only. Pick-to: 6.2 Task-number: QTBUG-87580 Change-Id: I53c7b26d6e17c3e0b1853622aa86c9953be37063 Reviewed-by: Joerg Bornemann <joerg.bornemann@qt.io>
Diffstat (limited to 'tests/auto/CMakeLists.txt')
-rw-r--r--tests/auto/CMakeLists.txt8
1 files changed, 6 insertions, 2 deletions
diff --git a/tests/auto/CMakeLists.txt b/tests/auto/CMakeLists.txt
index 005aefbc21..b2d91522d0 100644
--- a/tests/auto/CMakeLists.txt
+++ b/tests/auto/CMakeLists.txt
@@ -1,4 +1,9 @@
-# Generated from auto.pro.
+add_subdirectory(cmake)
+
+# Limit set of tests to run for static Qt builds.
+if(QT_BUILD_MINIMAL_STATIC_TESTS)
+ return()
+endif()
if(TARGET Qt::Quick)
add_subdirectory(qml)
@@ -8,7 +13,6 @@ endif()
if(TARGET Qt::QuickTest)
add_subdirectory(core)
endif()
-add_subdirectory(cmake)
add_subdirectory(toolsupport)
if(NOT UIKIT)
add_subdirectory(qmltest)