aboutsummaryrefslogtreecommitdiffstats
path: root/tests/auto/CMakeLists.txt
diff options
context:
space:
mode:
authorAssam Boudjelthia <assam.boudjelthia@qt.io>2021-10-12 16:29:32 +0300
committerAssam Boudjelthia <assam.boudjelthia@qt.io>2021-10-13 12:03:41 +0000
commit5a55e526382f0bb6eb647c2e6b7ce55661889990 (patch)
tree0c66f2ae945de0a6f05aff4c66dc7fd6446f84dd /tests/auto/CMakeLists.txt
parentf2a15482ddd289a36b04316a2b6ebed83eb017c5 (diff)
Android: Disable qjstest and qml ecmascripttests tests
qjstest and ecmascripttests fail to be configured on Android, and require CMake API changes to fix that. They could be disabled in the meantime to allow CI builds to proceed when building tests for other modules that depend on qtdeclarative. Task-number: QTBUG-92591 Task-number: QTBUG-88846 Pick-to: 6.2 Change-Id: I58e17166efc844efd089cce44d81dba027e9198c Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'tests/auto/CMakeLists.txt')
-rw-r--r--tests/auto/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/tests/auto/CMakeLists.txt b/tests/auto/CMakeLists.txt
index b2d91522d0..2476a8fe76 100644
--- a/tests/auto/CMakeLists.txt
+++ b/tests/auto/CMakeLists.txt
@@ -14,7 +14,7 @@ if(TARGET Qt::QuickTest)
add_subdirectory(core)
endif()
add_subdirectory(toolsupport)
-if(NOT UIKIT)
+if(NOT UIKIT AND NOT ANDROID) # FIXME: QTBUG-92591
add_subdirectory(qmltest)
endif()
if(TARGET Qt::Quick)