aboutsummaryrefslogtreecommitdiffstats
path: root/tests/auto/CMakeLists.txt
diff options
context:
space:
mode:
authorAssam Boudjelthia <assam.boudjelthia@qt.io>2022-02-17 17:09:40 +0200
committerAssam Boudjelthia <assam.boudjelthia@qt.io>2022-03-02 13:21:09 +0000
commit6c3373109fedf45b06c9c48355a80922fd754b31 (patch)
tree05421beed2f85d751d30c1d596dc34f5f43ea65c /tests/auto/CMakeLists.txt
parent9bdfea7f1f1ffe16c7a1140b09c94b9d72d24f18 (diff)
Disable failing declarative tests on Android - Part 2
This allows us to enable testing on declarative for the module as a whole and have some sort of test verification for the mean time, and fix the fails over time. This also disable tests like qdom and qjsscope which are host tests. Pick-to: 6.2 6.3 Task-number: QTBUG-100991 Task-number: QTBUG-99194 Task-number: QTBUG-101005 Task-number: QTBUG-101006 Change-Id: Ie7ae5b8e0ccdf2f55ce3568091d513a073c48417 Reviewed-by: Mitch Curtis <mitch.curtis@qt.io>
Diffstat (limited to 'tests/auto/CMakeLists.txt')
-rw-r--r--tests/auto/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/tests/auto/CMakeLists.txt b/tests/auto/CMakeLists.txt
index f2d0ca547a..3ef1b6e735 100644
--- a/tests/auto/CMakeLists.txt
+++ b/tests/auto/CMakeLists.txt
@@ -23,7 +23,7 @@ endif()
if(TARGET Qt::QuickWidgets)
add_subdirectory(quickwidgets)
endif()
-if(TARGET Qt::QmlDomPrivate)
+if(TARGET Qt::QmlDomPrivate AND NOT CMAKE_CROSSCOMPILING)
add_subdirectory(qmldom)
add_subdirectory(qmlls)
endif()