aboutsummaryrefslogtreecommitdiffstats
path: root/tests/auto/qml/qmltc/CMakeLists.txt
diff options
context:
space:
mode:
authorAndrei Golubev <andrei.golubev@qt.io>2021-12-14 17:20:15 +0100
committerAndrei Golubev <andrei.golubev@qt.io>2021-12-18 14:40:19 +0100
commit362b4bf3d6df1e1799a163d3e6d7ee39f75ad080 (patch)
treef80e94f4bded1e82bab0a374d38c6c4007d4c0f7 /tests/auto/qml/qmltc/CMakeLists.txt
parent844a939af5607c51d724658351b533aaa2b4508a (diff)
qmltc: Be aware of Component-wrapped types
While implicit components (the ones bound to Component-based property) are covered, cases like `Component { Text{} }` are not, so fix that Revisit the logic in the QmlIR / QQmlJSScope passes and code generator as part of this This might be a fairly used pattern in QML so no reason not to address this right away, especially given that we have most of the infrastructure in place already While at it, bring over extra tests that some other (non-merged) commit introduced. These give good coverage for missing cases and also exercise the feature supported here Task-number: QTBUG-84368 Pick-to: 6.3 Change-Id: I8f5c74fc79380566475b1139d4cc5560fac123e3 Reviewed-by: Ulf Hermann <ulf.hermann@qt.io>
Diffstat (limited to 'tests/auto/qml/qmltc/CMakeLists.txt')
-rw-r--r--tests/auto/qml/qmltc/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/auto/qml/qmltc/CMakeLists.txt b/tests/auto/qml/qmltc/CMakeLists.txt
index 1f58eaa3c9..92573f3fc6 100644
--- a/tests/auto/qml/qmltc/CMakeLists.txt
+++ b/tests/auto/qml/qmltc/CMakeLists.txt
@@ -20,6 +20,7 @@ set(qml_sources
data/methods.qml
data/properties.qml
data/ObjectWithId.qml
+ data/documentWithIds.qml
data/signalHandlers.qml
data/javaScriptFunctions.qml