aboutsummaryrefslogtreecommitdiffstats
path: root/tests/auto/qml/qmltc/CMakeLists.txt
diff options
context:
space:
mode:
authorAndrei Golubev <andrei.golubev@qt.io>2021-12-17 11:49:46 +0100
committerAndrei Golubev <andrei.golubev@qt.io>2021-12-23 15:56:16 +0100
commit71084db1df9453aa9c657b91f2dab6766a56903b (patch)
treef524bfb5397601f7b78ae525381eee21d2e6a2c1 /tests/auto/qml/qmltc/CMakeLists.txt
parent2dc1080f5f14c0b15a40e210d17a403c7490a18e (diff)
qmltc: Support different property change handlers
qmltc must be able to compile property change handlers: - for bindable properties (with no notify) - for notifiable properties (with no bindable) - for both bindable and notifiable properties (preferring notify signal) Test the aforementioned cases and some signal handling cases along the way Task-number: QTBUG-84368 Pick-to: 6.3 Change-Id: I2cd2d0ad6407889942c806e03831dec4c7ce265a Reviewed-by: Fawzi Mohamed <fawzi.mohamed@qt.io>
Diffstat (limited to 'tests/auto/qml/qmltc/CMakeLists.txt')
-rw-r--r--tests/auto/qml/qmltc/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/tests/auto/qml/qmltc/CMakeLists.txt b/tests/auto/qml/qmltc/CMakeLists.txt
index fc1d88e56a..f104b723a0 100644
--- a/tests/auto/qml/qmltc/CMakeLists.txt
+++ b/tests/auto/qml/qmltc/CMakeLists.txt
@@ -10,6 +10,8 @@ set(cpp_sources
# private properties:
cpptypes/testprivateproperty.h cpptypes/testprivateproperty.cpp
cpptypes/private/testprivateproperty_p.h
+
+ cpptypes/typewithproperties.h cpptypes/typewithproperties.cpp
)
set(qml_sources
@@ -64,6 +66,7 @@ set(qml_sources
data/PrivateProperty.qml
data/privatePropertySubclass.qml
data/calqlatrBits.qml
+ data/propertyChangeAndSignalHandlers.qml
# support types:
data/DefaultPropertySingleChild.qml