aboutsummaryrefslogtreecommitdiffstats
path: root/tests/auto/qml/qmltc/CMakeLists.txt
diff options
context:
space:
mode:
authorAndrei Golubev <andrei.golubev@qt.io>2021-09-17 17:01:56 +0200
committerAndrei Golubev <andrei.golubev@qt.io>2021-10-22 12:47:19 +0200
commit8dab4a81a0bf6cf1765ecf15f6f8c5b9ac2f5100 (patch)
tree167fed54732edfc76a171e0c0f57643367d4378a /tests/auto/qml/qmltc/CMakeLists.txt
parent325938018be24fa54b2d06d9e16b040a925580f3 (diff)
qmltc: add cmake api and simplest file writer
Also update tests to include the generated file. While the content is meaningless, it's good enough to check that the file is include-able at this stage Task-number: QTBUG-84368 Task-number: QTBUG-96040 Change-Id: I155826a52090c5b13d14be6330813dc5a27f28e5 Reviewed-by: Ulf Hermann <ulf.hermann@qt.io>
Diffstat (limited to 'tests/auto/qml/qmltc/CMakeLists.txt')
-rw-r--r--tests/auto/qml/qmltc/CMakeLists.txt15
1 files changed, 15 insertions, 0 deletions
diff --git a/tests/auto/qml/qmltc/CMakeLists.txt b/tests/auto/qml/qmltc/CMakeLists.txt
index 8823e452e7..ae83ffc45c 100644
--- a/tests/auto/qml/qmltc/CMakeLists.txt
+++ b/tests/auto/qml/qmltc/CMakeLists.txt
@@ -1,11 +1,18 @@
set(cpp_sources
tst_qmltc.h tst_qmltc.cpp
+
+ # test files:
+ nameconflict.h nameconflict.cpp
)
set(qml_sources
data/HelloWorld.qml
+ data/NameConflict.qml
)
+set_source_files_properties(data/NameConflict.qml PROPERTIES
+ QT_QMLTC_FILE_BASENAME data/ResolvedNameConflict)
+
qt_internal_add_test(tst_qmltc_diskcache
SOURCES
${cpp_sources}
@@ -24,6 +31,10 @@ qt6_add_qml_module(tst_qmltc_diskcache
target_compile_definitions(tst_qmltc_diskcache PRIVATE
QMLTC_TESTS_DISABLE_CACHE=0
)
+qt6_target_compile_qml_to_cpp(tst_qmltc_diskcache
+ FILES
+ ${qml_sources}
+)
qt_internal_add_test(tst_qmltc_nodiskcache
SOURCES
@@ -43,3 +54,7 @@ qt6_add_qml_module(tst_qmltc_nodiskcache
target_compile_definitions(tst_qmltc_nodiskcache PRIVATE
QMLTC_TESTS_DISABLE_CACHE=1
)
+qt6_target_compile_qml_to_cpp(tst_qmltc_nodiskcache
+ FILES
+ ${qml_sources}
+)