aboutsummaryrefslogtreecommitdiffstats
path: root/tests/auto/qml/qmltc/CMakeLists.txt
diff options
context:
space:
mode:
authorAndrei Golubev <andrei.golubev@qt.io>2021-11-01 14:23:17 +0100
committerAndrei Golubev <andrei.golubev@qt.io>2021-11-09 15:14:27 +0100
commitd4a28c6adc57f3e6f774f3ff338589591ff6fae4 (patch)
tree2737ed5bb930d67d695a499603879b8b7ceb5b90 /tests/auto/qml/qmltc/CMakeLists.txt
parent7f018794beebf360bf375e065d2547c71150fdf6 (diff)
qt6_target_compile_qml_to_cpp: improve QT_QMLTC_FILE_BASENAME handling
Let's simplify the whole output path logic for .cpp and .h: - there's really little use in relative prefixes (e.g. we don't need data/ in data/HelloWorld.qml to operate) - similarly, let's ignore/discourage the use of such prefixes in QT_QMLTC_FILE_BASENAME. I envision poor output dir structure otherwise (not that anyone will notice it anyway) As a drive by, also replace CMAKE_CURRENT_*_DIR with target_*_dir as we should really use target's dir structure, not the (potentially wrong) current dir structure Task-number: QTBUG-96040 Change-Id: Ib9a108941e5179809855d28003ec157a07163c0e Reviewed-by: Ulf Hermann <ulf.hermann@qt.io>
Diffstat (limited to 'tests/auto/qml/qmltc/CMakeLists.txt')
-rw-r--r--tests/auto/qml/qmltc/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/tests/auto/qml/qmltc/CMakeLists.txt b/tests/auto/qml/qmltc/CMakeLists.txt
index ae83ffc45c..dd601b9fac 100644
--- a/tests/auto/qml/qmltc/CMakeLists.txt
+++ b/tests/auto/qml/qmltc/CMakeLists.txt
@@ -11,7 +11,7 @@ set(qml_sources
)
set_source_files_properties(data/NameConflict.qml PROPERTIES
- QT_QMLTC_FILE_BASENAME data/ResolvedNameConflict)
+ QT_QMLTC_FILE_BASENAME ResolvedNameConflict)
qt_internal_add_test(tst_qmltc_diskcache
SOURCES