aboutsummaryrefslogtreecommitdiffstats
path: root/tests/auto/qml/qmltc/CMakeLists.txt
diff options
context:
space:
mode:
authorMaximilian Goldstein <max.goldstein@qt.io>2022-01-18 13:08:09 +0100
committerMaximilian Goldstein <max.goldstein@qt.io>2022-02-03 11:17:34 +0100
commitdc9de38abe797e835480171a047bf96e98c84e1f (patch)
tree1ce1b77174fdc38c45a23555399a665591da2b80 /tests/auto/qml/qmltc/CMakeLists.txt
parenta0f5baad2a645bfaa65773451e9d76944ae9a951 (diff)
qmllint: Warn about missing singleton pragmas/qmldir entries
This change adds a warning if we encounter a component marked as a singleton in a qmldir file which does not contain a pragma Singleton entry and vice versa. Note that the warning only gets triggered if the singleton is actually used. Fixes: QTBUG-98558 Change-Id: Id7c63f48ba49759c15dffcaee0270c7caab2eb7d Reviewed-by: Andrei Golubev <andrei.golubev@qt.io>
Diffstat (limited to 'tests/auto/qml/qmltc/CMakeLists.txt')
-rw-r--r--tests/auto/qml/qmltc/CMakeLists.txt1
1 files changed, 0 insertions, 1 deletions
diff --git a/tests/auto/qml/qmltc/CMakeLists.txt b/tests/auto/qml/qmltc/CMakeLists.txt
index 4f468c41e9..1c15d9b1fb 100644
--- a/tests/auto/qml/qmltc/CMakeLists.txt
+++ b/tests/auto/qml/qmltc/CMakeLists.txt
@@ -14,7 +14,6 @@ set(qmltc_module_libs
# automatic type registration that comes from the plugin)
qmltc_test_moduleplugin
)
-
qt_internal_add_test(tst_qmltc_diskcache
SOURCES ${test_sources}
LIBRARIES ${qmltc_module_libs}