aboutsummaryrefslogtreecommitdiffstats
path: root/tests/auto/qml/qqmlapplicationengine/CMakeLists.txt
diff options
context:
space:
mode:
authorOlivier De Cannière <olivier.decanniere@qt.io>2024-01-17 17:41:29 +0100
committerOlivier De Cannière <olivier.decanniere@qt.io>2024-03-21 14:34:32 +0100
commit986b4d155bd39836b1aa3c3da332ef07d2a949fd (patch)
tree02c04716d3d5627ff95b68015f4febac24c0b8ae /tests/auto/qml/qqmlapplicationengine/CMakeLists.txt
parent050fa38d65bebe56ab599acdaaa65b8ed12c8a8b (diff)
QQmlEngine: Set translationsDirectory in loadFromModule
In the process, loadFromModule had to be split in two parts. The type resolution has to happen so that the translationDirectory can be set and the translations have to be loaded before loading the actual module. Pick-to: 6.7 6.5 Fixes: QTBUG-116589 Change-Id: Ife7999f418ba35bfb0eed9050198e5a886fa74ae Reviewed-by: Fabian Kosmale <fabian.kosmale@qt.io>
Diffstat (limited to 'tests/auto/qml/qqmlapplicationengine/CMakeLists.txt')
-rw-r--r--tests/auto/qml/qqmlapplicationengine/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/tests/auto/qml/qqmlapplicationengine/CMakeLists.txt b/tests/auto/qml/qqmlapplicationengine/CMakeLists.txt
index eac3ce706d..3b02ed09ef 100644
--- a/tests/auto/qml/qqmlapplicationengine/CMakeLists.txt
+++ b/tests/auto/qml/qqmlapplicationengine/CMakeLists.txt
@@ -63,5 +63,12 @@ qt_internal_extend_target(tst_qqmlapplicationengine CONDITION NOT ANDROID AND NO
DEFINES
QT_QMLTEST_DATADIR="${CMAKE_CURRENT_SOURCE_DIR}/data"
)
+
add_subdirectory(testapp)
add_subdirectory(androidassets)
+add_dependencies(tst_qqmlapplicationengine testapp)
+
+add_subdirectory(loadFromModuleTranslationsQmlType)
+add_subdirectory(loadFromModuleTranslationsCppType)
+add_dependencies(tst_qqmlapplicationengine i18nLoadFromModuleQmlType)
+add_dependencies(tst_qqmlapplicationengine i18nLoadFromModuleCppType)