aboutsummaryrefslogtreecommitdiffstats
path: root/tests/auto/qml/qqmlparser/CMakeLists.txt
diff options
context:
space:
mode:
authorFabian Kosmale <fabian.kosmale@qt.io>2021-11-12 15:41:12 +0100
committerFabian Kosmale <fabian.kosmale@qt.io>2021-11-13 09:13:00 +0100
commitd7c2c884cf05efefdcbdd922805e1a779ca43e29 (patch)
tree28c4beedfee696a48a23d0fed9422ecca80f1caa /tests/auto/qml/qqmlparser/CMakeLists.txt
parent91ed4cdae1db4f051ac5dddd8b9197c96cf28ac3 (diff)
Purge old AST dumper and use the functionality provided by the QML DOM
This reduces the number of AST visitors we need to maintain. Change-Id: I9b55706092b4b285816fe6680c94116694bd1f05 Reviewed-by: Ulf Hermann <ulf.hermann@qt.io>
Diffstat (limited to 'tests/auto/qml/qqmlparser/CMakeLists.txt')
-rw-r--r--tests/auto/qml/qqmlparser/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/auto/qml/qqmlparser/CMakeLists.txt b/tests/auto/qml/qqmlparser/CMakeLists.txt
index 004bb8ea31..fd805b8d96 100644
--- a/tests/auto/qml/qqmlparser/CMakeLists.txt
+++ b/tests/auto/qml/qqmlparser/CMakeLists.txt
@@ -19,6 +19,7 @@ qt_internal_add_test(tst_qqmlparser
Qt::Gui
Qt::QmlPrivate
Qt::QuickTestUtilsPrivate
+ Qt::QmlDomPrivate
TESTDATA ${test_data}
)