aboutsummaryrefslogtreecommitdiffstats
path: root/tests/auto/qmltest/fuzzycompare/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2023-06-29 18:11:18 +0200
committerAlexandru Croitor <alexandru.croitor@qt.io>2023-07-05 12:34:12 +0200
commit1e5252f82e2c4e0c7922a21f5442ffbd534d2a15 (patch)
treec01f93648d3783cf923ec8e86c44292c0ecda0fc /tests/auto/qmltest/fuzzycompare/CMakeLists.txt
parent1858e6c7b17b6233b8a5135915a789a1780d1e16 (diff)
CMake: Make qtdeclarative tests standalone projects
Add the boilerplate standalone test prelude to each test, so that they can be opened with an IDE without the qt-cmake-standalone-test script, but directly with qt-cmake or cmake. Boilerplate was added using the follow script: https://git.qt.io/alcroito/cmake_refactor Manual adjustments were made where the code was inserted in the wrong location. Task-number: QTBUG-93020 Change-Id: Ibd12efab09ceb5852395e40f10b55fafb69c1b58 Reviewed-by: Amir Masoud Abdol <amir.abdol@qt.io> Reviewed-by: Joerg Bornemann <joerg.bornemann@qt.io>
Diffstat (limited to 'tests/auto/qmltest/fuzzycompare/CMakeLists.txt')
-rw-r--r--tests/auto/qmltest/fuzzycompare/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/tests/auto/qmltest/fuzzycompare/CMakeLists.txt b/tests/auto/qmltest/fuzzycompare/CMakeLists.txt
index 4c93595376..83b505af71 100644
--- a/tests/auto/qmltest/fuzzycompare/CMakeLists.txt
+++ b/tests/auto/qmltest/fuzzycompare/CMakeLists.txt
@@ -7,6 +7,12 @@
## fuzzycompare Test:
#####################################################################
+if(NOT QT_BUILD_STANDALONE_TESTS AND NOT QT_BUILDING_QT)
+ cmake_minimum_required(VERSION 3.16)
+ project(fuzzycompare LANGUAGES CXX)
+ find_package(Qt6BuildInternals REQUIRED COMPONENTS STANDALONE_TEST)
+endif()
+
qt_internal_add_test(fuzzycompare
GUI
QMLTEST