aboutsummaryrefslogtreecommitdiffstats
path: root/tests/manual/CMakeLists.txt
diff options
context:
space:
mode:
authorDmitrii Akshintsev <dmitrii.akshintsev@qt.io>2024-04-22 16:49:00 +0200
committerDmitrii Akshintsev <dmitrii.akshintsev@qt.io>2024-04-23 20:33:38 +0200
commitcb43a85ba74cbc6a34c819262cc6b0196f0e6fe3 (patch)
tree30e19f3e6b257475c1829be58340bc161cf56425 /tests/manual/CMakeLists.txt
parentc2a65fbe04bbcac066a8bf1527d064d4866efbfe (diff)
qmlformat: "Move" testExample e2e tests to /manual
testExample, normalizeExample and actually most of the tests in tst_qmlformat are e2e tests and in general QmlFormat lacks unit test coverage, compensating it with e2e. The biggest problem atm that some of those tests (namely testExample) take too much time to execute because it runs QmlFormat over almost all files in examples and tests directories. Unfortunately atm our QA&QE infra can't provide tools for an easy automated setup of potentially time-consuming tests. As a workaround this commit: 1. "Moves" testExample and normalizeExample to the /manual tests 2. Preserves a very small fraction of testData for automated testing "just in case" Steps to repro: 1. configure with the flag `-make manual-tests` 2. `ninja e2e_qmlformat` 3. run ;) Fixes: QTBUG-122990 Change-Id: Id41baee15e8826f4def5787f62790ed46f00e5dc Reviewed-by: Ulf Hermann <ulf.hermann@qt.io>
Diffstat (limited to 'tests/manual/CMakeLists.txt')
-rw-r--r--tests/manual/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/manual/CMakeLists.txt b/tests/manual/CMakeLists.txt
index 14d637b9af..95845fea8e 100644
--- a/tests/manual/CMakeLists.txt
+++ b/tests/manual/CMakeLists.txt
@@ -35,3 +35,4 @@ if(TARGET Qt::QuickVectorImage)
add_subdirectory(quickvectorimage)
add_subdirectory(svg)
endif()
+add_subdirectory(e2e)