aboutsummaryrefslogtreecommitdiffstats
path: root/tests/manual/pointer/CMakeLists.txt
diff options
context:
space:
mode:
authorShawn Rutledge <shawn.rutledge@qt.io>2021-09-06 21:40:18 +0200
committerShawn Rutledge <shawn.rutledge@qt.io>2021-09-24 17:03:19 +0200
commit8503f884bbdb50c4bebc8f8a9fce05275b0612b1 (patch)
treec4a28a0df334841a49d6653ffd02c38aca54b68a /tests/manual/pointer/CMakeLists.txt
parent11b358a82cd4b1570f32c53808ef974bf11ffb9d (diff)
Move most of the pointer manual tests to a new pointerhandlers example
They were always meant to be examples eventually. Now they will be used for an example of how to implement custom controls using only basic items and handlers. Some components are very similar to those in the shared directory; but most examples will use Qt Quick Controls, so those shared components can be removed when we no longer use them. This example should remain as the one that shows how to build reusable controls "from scratch". Removed InputInspector because it's inefficient, has limited usefulness, tends to require building the manual test to be able to run it, and could be better built as a reusable Qt.labs component later on, providing a model with all known devices and taking advantage of the QPointingDevice::grabChanged signal to track the grab states rather than polling. Pick-to: 6.2 Change-Id: I47ab6ebb2cecab07a69cf96e546ffd0db3026a60 Reviewed-by: Fabian Kosmale <fabian.kosmale@qt.io> Reviewed-by: Oliver Eftevaag <oliver.eftevaag@qt.io> Reviewed-by: Shawn Rutledge <shawn.rutledge@qt.io>
Diffstat (limited to 'tests/manual/pointer/CMakeLists.txt')
-rw-r--r--tests/manual/pointer/CMakeLists.txt110
1 files changed, 0 insertions, 110 deletions
diff --git a/tests/manual/pointer/CMakeLists.txt b/tests/manual/pointer/CMakeLists.txt
deleted file mode 100644
index aa8e15306b..0000000000
--- a/tests/manual/pointer/CMakeLists.txt
+++ /dev/null
@@ -1,110 +0,0 @@
-# Generated from pointer.pro.
-
-#####################################################################
-## pointer Binary:
-#####################################################################
-
-# special case begin
-if(NOT TARGET Qt::Svg OR NOT TARGET Qt::Quick OR NOT TARGET Qt::Qml)
- return()
-endif()
-# special case end
-
-qt_internal_add_manual_test(pointer
- GUI
- SOURCES
- inputinspector.cpp inputinspector.h
- main.cpp
- PUBLIC_LIBRARIES
- Qt::Gui
- Qt::Qml
- Qt::Quick
- Qt::QuickPrivate
- Qt::Svg
-)
-
-# Resources:
-set(qml_resource_files
- "content/CheckBox.qml"
- "content/FakeFlickable.qml"
- "content/FlashAnimation.qml"
- "content/MomentumAnimation.qml"
- "content/MouseAreaButton.qml"
- "content/MouseAreaSlider.qml"
- "content/MouseFeedbackSprite.qml"
- "content/MptaButton.qml"
- "content/MultiButton.qml"
- "content/ScrollBar.qml"
- "content/Slider.qml"
- "content/TapHandlerButton.qml"
- "content/TextBox.qml"
- "content/TouchpointFeedbackSprite.qml"
- "fakeFlickable.qml"
- "flickablesWithHandlers.qml"
- "flingAnimation.qml"
- "joystick.qml"
- "main.qml"
- "map.qml"
- "map2.qml"
- "mixer.qml"
- "multibuttons.qml"
- "photosurface.qml"
- "pinchHandler.qml"
- "pointerDrag.qml"
- "resources/arrowhead.png"
- "resources/balloon.png"
- "resources/cursor-airbrush.png"
- "resources/cursor-eraser.png"
- "resources/cursor-felt-marker.png"
- "resources/cursor-pencil.png"
- "resources/fighter.png"
- "resources/fingersprite.png"
- "resources/grabbing-location.svg"
- "resources/joystick-outer-case-pov.jpg"
- "resources/map.svgz"
- "resources/missile.png"
- "resources/mixer-knob.png"
- "resources/mouse.png"
- "resources/mouse_left.png"
- "resources/mouse_middle.png"
- "resources/mouse_right.png"
- "resources/redball.png"
- "sidebar.qml"
- "singlePointHandlerProperties.qml"
- "tabletCanvasDrawing.qml"
- "tapHandler.qml"
-)
-
-qt_internal_add_resource(pointer "qml"
- PREFIX
- "/"
- FILES
- ${qml_resource_files}
-)
-set(quick_shared_resource_files
- "../../../examples/quick/shared/Button.qml"
- "../../../examples/quick/shared/CheckBox.qml"
- "../../../examples/quick/shared/Label.qml"
- "../../../examples/quick/shared/LauncherList.qml"
- "../../../examples/quick/shared/SimpleLauncherDelegate.qml"
- "../../../examples/quick/shared/Slider.qml"
- "../../../examples/quick/shared/TextField.qml"
- "../../../examples/quick/shared/images/back.png"
- "../../../examples/quick/shared/images/checkmark.png"
- "../../../examples/quick/shared/images/next.png"
- "../../../examples/quick/shared/images/slider_handle.png"
-)
-
-qt_internal_add_resource(pointer "quick_shared"
- PREFIX
- "/quick/shared"
- BASE
- "../../../examples/quick/shared"
- FILES
- ${quick_shared_resource_files}
-)
-
-qt_import_qml_plugins(pointer) # special case
-
-#### Keys ignored in scope 1:.:.:pointer.pro:<TRUE>:
-# TEMPLATE = "app"