aboutsummaryrefslogtreecommitdiffstats
path: root/tools/qmllint/CMakeLists.txt
diff options
context:
space:
mode:
authorJoerg Bornemann <joerg.bornemann@qt.io>2021-09-27 13:36:54 +0200
committerJoerg Bornemann <joerg.bornemann@qt.io>2021-10-08 10:37:35 +0200
commit0d6d3c7bc50e1ab08b66449b7bb9239a97bfed4e (patch)
treeead4dee258c1d2ee6cacdc79cc620be9492e3747 /tools/qmllint/CMakeLists.txt
parent49e549934dbd993e9e352a5719f85d1a5475a2f5 (diff)
Skip unnecessary commands when cross-building tools
Call qt_internal_return_unless_building_tools() directly after qt_internal_add_tool() to avoid having to special-case code for when this function only creates imported targets in cross-builds. Task-number: QTBUG-85084 Change-Id: I5c8f2ecdf4936cfd15cb530e896bc4e5b5531620 Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'tools/qmllint/CMakeLists.txt')
-rw-r--r--tools/qmllint/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/tools/qmllint/CMakeLists.txt b/tools/qmllint/CMakeLists.txt
index ba6eef92ef..4107e10f74 100644
--- a/tools/qmllint/CMakeLists.txt
+++ b/tools/qmllint/CMakeLists.txt
@@ -19,6 +19,7 @@ qt_internal_add_tool(${target_name}
Qt::CorePrivate
Qt::QmlCompilerPrivate
)
+qt_internal_return_unless_building_tools()
#### Keys ignored in scope 1:.:.:qmllint.pro:<TRUE>:
# QMAKE_TARGET_DESCRIPTION = "QML" "Syntax" "Verifier"