aboutsummaryrefslogtreecommitdiffstats
path: root/tools/qmllint/CMakeLists.txt
diff options
context:
space:
mode:
authorMaximilian Goldstein <max.goldstein@qt.io>2021-07-05 12:48:49 +0200
committerMaximilian Goldstein <max.goldstein@qt.io>2021-07-07 14:03:21 +0200
commit67894892da4c4f9985307e8cfc76aad766de88ac (patch)
tree0a18866189ab8f3cadb8a182d538f871de6cd21b /tools/qmllint/CMakeLists.txt
parenteb8925682462c78fe5879d61662eb739b972e981 (diff)
qmllint: Integrate type inference warnings
This change helps bring in type inference and compiler warnings previously only generated by qmlcachegen+. These warnings are disabled by default and have to be enabled manually via the --compiler option. Also makes the logger handle zero length SourceLocations properly by just highlighting the entire line instead of hitting an assert. Change-Id: Iebad6e9236214d9367f97487e7b5787592edab7d Reviewed-by: Fabian Kosmale <fabian.kosmale@qt.io> Reviewed-by: Andrei Golubev <andrei.golubev@qt.io>
Diffstat (limited to 'tools/qmllint/CMakeLists.txt')
-rw-r--r--tools/qmllint/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/tools/qmllint/CMakeLists.txt b/tools/qmllint/CMakeLists.txt
index b27451fe9d..2226e5cd81 100644
--- a/tools/qmllint/CMakeLists.txt
+++ b/tools/qmllint/CMakeLists.txt
@@ -11,6 +11,7 @@ qt_internal_add_tool(${target_name}
SOURCES
checkidentifiers.cpp checkidentifiers.h
findwarnings.cpp findwarnings.h
+ codegen.cpp codegen.h
main.cpp
../shared/qqmltoolingsettings.h
../shared/qqmltoolingsettings.cpp