aboutsummaryrefslogtreecommitdiffstats
path: root/tools/qmllint/CMakeLists.txt
diff options
context:
space:
mode:
authorFawzi Mohamed <fawzi.mohamed@qt.io>2021-07-01 02:17:33 +0200
committerFawzi Mohamed <fawzi.mohamed@qt.io>2021-07-02 12:06:21 +0200
commit70dac58bd9193be7668fba482391933122fff48f (patch)
tree47b75040be487611caa2acc513091f605dcece03 /tools/qmllint/CMakeLists.txt
parent3395bed6c7d02cc09b1902b6c5a0ce16c87257e3 (diff)
replace devtools library with QtQml
qmldevtools was needed when building with qmake, and to avoid circular dependencies in the tools (before making QtQml minimal). Now it can be avoided. This change will make qmldom, qmlformat, qmlimportscanner and qmllint depend on QtQml (just like the other Qml tools) and not be always completely static (qmldevtools was always a static library, QtQml normally isn't). Change-Id: Idfa0a70e51f0d4999fb9753121c6c228ae69c9bb Reviewed-by: Ulf Hermann <ulf.hermann@qt.io> Reviewed-by: Andrei Golubev <andrei.golubev@qt.io> Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org>
Diffstat (limited to 'tools/qmllint/CMakeLists.txt')
-rw-r--r--tools/qmllint/CMakeLists.txt1
1 files changed, 0 insertions, 1 deletions
diff --git a/tools/qmllint/CMakeLists.txt b/tools/qmllint/CMakeLists.txt
index 8e9a737f5a..b27451fe9d 100644
--- a/tools/qmllint/CMakeLists.txt
+++ b/tools/qmllint/CMakeLists.txt
@@ -17,7 +17,6 @@ qt_internal_add_tool(${target_name}
PUBLIC_LIBRARIES
Qt::CorePrivate
Qt::QmlCompilerPrivate
- Qt::QmlDevToolsPrivate
)
#### Keys ignored in scope 1:.:.:qmllint.pro:<TRUE>: