aboutsummaryrefslogtreecommitdiffstats
path: root/examples/quick/particles/imageparticle/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/quick/particles/imageparticle/CMakeLists.txt')
-rw-r--r--examples/quick/particles/imageparticle/CMakeLists.txt8
1 files changed, 3 insertions, 5 deletions
diff --git a/examples/quick/particles/imageparticle/CMakeLists.txt b/examples/quick/particles/imageparticle/CMakeLists.txt
index 387c5bdd41..41eab03f36 100644
--- a/examples/quick/particles/imageparticle/CMakeLists.txt
+++ b/examples/quick/particles/imageparticle/CMakeLists.txt
@@ -1,24 +1,22 @@
cmake_minimum_required(VERSION 3.16)
project(imageparticle LANGUAGES CXX)
-set(CMAKE_INCLUDE_CURRENT_DIR ON)
-
set(CMAKE_AUTOMOC ON)
-set(CMAKE_AUTORCC ON)
if(NOT DEFINED INSTALL_EXAMPLESDIR)
- set(INSTALL_EXAMPLESDIR "examples")
+ set(INSTALL_EXAMPLESDIR "examples")
endif()
set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/quick/particles/imageparticle")
-find_package(Qt6 COMPONENTS Core Gui Quick Qml)
+find_package(Qt6 REQUIRED COMPONENTS Core Gui Qml Quick)
add_subdirectory("../../shared" "shared")
qt_add_executable(imageparticleexample WIN32 MACOSX_BUNDLE
main.cpp
)
+
target_link_libraries(imageparticleexample PUBLIC
Qt::Core
Qt::Gui