aboutsummaryrefslogtreecommitdiffstats
path: root/examples/quick/scenegraph/custommaterial/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/quick/scenegraph/custommaterial/CMakeLists.txt')
-rw-r--r--examples/quick/scenegraph/custommaterial/CMakeLists.txt24
1 files changed, 8 insertions, 16 deletions
diff --git a/examples/quick/scenegraph/custommaterial/CMakeLists.txt b/examples/quick/scenegraph/custommaterial/CMakeLists.txt
index cbf6b0b5c7..a8ead8e39b 100644
--- a/examples/quick/scenegraph/custommaterial/CMakeLists.txt
+++ b/examples/quick/scenegraph/custommaterial/CMakeLists.txt
@@ -1,35 +1,27 @@
-# Generated from custommaterial.pro.
-
cmake_minimum_required(VERSION 3.16)
-project(custommaterial_declarative LANGUAGES CXX) # special case
-
-set(CMAKE_INCLUDE_CURRENT_DIR ON)
+project(custommaterial_declarative LANGUAGES CXX)
set(CMAKE_AUTOMOC ON)
-set(CMAKE_AUTORCC ON)
-set(CMAKE_AUTOUIC ON)
if(NOT DEFINED INSTALL_EXAMPLESDIR)
- set(INSTALL_EXAMPLESDIR "examples")
+ set(INSTALL_EXAMPLESDIR "examples")
endif()
set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/quick/scenegraph/custommaterial")
-find_package(Qt6 COMPONENTS Core)
-find_package(Qt6 COMPONENTS Gui)
-find_package(Qt6 COMPONENTS Qml)
-find_package(Qt6 COMPONENTS Quick)
-find_package(Qt6 COMPONENTS ShaderTools)
+find_package(Qt6 REQUIRED COMPONENTS Core Gui Qml Quick ShaderTools)
-qt_add_executable(custommaterial_declarative # special case
+qt_add_executable(custommaterial_declarative
customitem.cpp customitem.h
main.cpp
)
+
set_target_properties(custommaterial_declarative PROPERTIES
WIN32_EXECUTABLE TRUE
MACOSX_BUNDLE TRUE
)
-target_link_libraries(custommaterial_declarative PUBLIC # special case
+
+target_link_libraries(custommaterial_declarative PUBLIC
Qt::Core
Qt::Gui
Qt::Qml
@@ -56,7 +48,7 @@ qt6_add_shaders(custommaterial_declarative "shaders"
"shaders/mandelbrot.frag"
)
-install(TARGETS custommaterial_declarative # special case
+install(TARGETS custommaterial_declarative
RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"