aboutsummaryrefslogtreecommitdiffstats
path: root/examples/quick/shared/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/quick/shared/CMakeLists.txt')
-rw-r--r--examples/quick/shared/CMakeLists.txt24
1 files changed, 1 insertions, 23 deletions
diff --git a/examples/quick/shared/CMakeLists.txt b/examples/quick/shared/CMakeLists.txt
index 159f1e8699..7382df7689 100644
--- a/examples/quick/shared/CMakeLists.txt
+++ b/examples/quick/shared/CMakeLists.txt
@@ -1,5 +1,5 @@
# Copyright (C) 2022 The Qt Company Ltd.
-# SPDX-License-Identifier: BSD-3-Clause
+# SPDX-License-Identifier: LicenseRef-Qt-Commercial OR BSD-3-Clause
set_source_files_properties(CheckBox.qml TabSet.qml TextField.qml
PROPERTIES
@@ -16,13 +16,11 @@ qt_add_qml_module(${PROJECT_NAME}_shared
URI shared
VERSION 2.2
PLUGIN_TARGET ${PROJECT_NAME}_shared
- AUTO_RESOURCE_PREFIX
SOURCES
"shared.h"
QML_FILES
"Button.qml"
"CheckBox.qml"
- "FlickrRssModel.qml"
"Label.qml"
"LauncherList.qml"
"SimpleLauncherDelegate.qml"
@@ -38,23 +36,3 @@ qt_add_qml_module(${PROJECT_NAME}_shared
"images/slider_handle.png"
"images/tab.png"
)
-
-include(QtBundleQmlModuleForMacOS.cmake)
-# Puts the shared qml module plugin and qmldir into the macOS app bundle directory.
-# Only call this function if your main project has the MACOSX_BUNDLE option set.
-function(bundle_shared app_target)
- set(qml_plugin_target "${PROJECT_NAME}_shared")
- set(qml_module_uri "shared")
- add_qml_module_to_macos_app_bundle(
- "${app_target}" "${qml_plugin_target}" "${qml_module_uri}")
-endfunction()
-
-set(INSTALL_SHAREDDIR "${INSTALL_EXAMPLESDIR}/quick/${PROJECT_NAME}/shared")
-install(TARGETS ${PROJECT_NAME}_shared
- RUNTIME DESTINATION "${INSTALL_SHAREDDIR}"
- LIBRARY DESTINATION "${INSTALL_SHAREDDIR}"
-)
-
-install(FILES ${CMAKE_CURRENT_BINARY_DIR}/qmldir
- DESTINATION "${INSTALL_SHAREDDIR}"
-)