aboutsummaryrefslogtreecommitdiffstats
path: root/examples/quickcontrols/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/quickcontrols/CMakeLists.txt')
-rw-r--r--examples/quickcontrols/CMakeLists.txt14
1 files changed, 7 insertions, 7 deletions
diff --git a/examples/quickcontrols/CMakeLists.txt b/examples/quickcontrols/CMakeLists.txt
index e4021bf430..362fa34698 100644
--- a/examples/quickcontrols/CMakeLists.txt
+++ b/examples/quickcontrols/CMakeLists.txt
@@ -1,21 +1,21 @@
# Copyright (C) 2022 The Qt Company Ltd.
-# SPDX-License-Identifier: BSD-3-Clause
+# SPDX-License-Identifier: LicenseRef-Qt-Commercial OR BSD-3-Clause
qt_internal_add_example(attachedstyleproperties)
qt_internal_add_example(gallery)
-if (TARGET Qt::Sql)
+if (TARGET Qt6::Sql)
add_subdirectory(chattutorial)
endif()
-if (QT_FEATURE_quicktemplates2_calendar AND TARGET Qt::Sql)
+if (QT_FEATURE_quicktemplates2_calendar AND TARGET Qt6::Sql)
qt_internal_add_example(eventcalendar)
endif()
qt_internal_add_example(texteditor)
qt_internal_add_example(contactlist)
-qt_internal_add_example(sidepanel)
-qt_internal_add_example(swipetoremove)
qt_internal_add_example(wearable)
qt_internal_add_example(imagine/automotive)
-qt_internal_add_example(imagine/musicplayer)
-if(TARGET Qt::Widgets)
+if (TARGET Qt6::Svg AND NOT ANDROID AND NOT IOS)
+ qt_internal_add_example(filesystemexplorer)
+endif()
+if(TARGET Qt6::Widgets)
qt_internal_add_example(flatstyle)
endif()