aboutsummaryrefslogtreecommitdiffstats
path: root/examples/quickcontrols/contactlist/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/quickcontrols/contactlist/CMakeLists.txt')
-rw-r--r--examples/quickcontrols/contactlist/CMakeLists.txt37
1 files changed, 20 insertions, 17 deletions
diff --git a/examples/quickcontrols/contactlist/CMakeLists.txt b/examples/quickcontrols/contactlist/CMakeLists.txt
index d353e3374f..7de83d98c3 100644
--- a/examples/quickcontrols/contactlist/CMakeLists.txt
+++ b/examples/quickcontrols/contactlist/CMakeLists.txt
@@ -1,19 +1,14 @@
-# Copyright (C) 2022 The Qt Company Ltd.
-# SPDX-License-Identifier: BSD-3-Clause
+# Copyright (C) 2023 The Qt Company Ltd.
+# SPDX-License-Identifier: LicenseRef-Qt-Commercial OR BSD-3-Clause
cmake_minimum_required(VERSION 3.16)
project(contactlist LANGUAGES CXX)
-set(CMAKE_AUTOMOC ON)
-
-if(NOT DEFINED INSTALL_EXAMPLESDIR)
- set(INSTALL_EXAMPLESDIR "examples")
-endif()
-
-set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/quickcontrols/contactlist")
find_package(Qt6 REQUIRED COMPONENTS Core Gui Quick)
+qt_standard_project_setup(REQUIRES 6.6)
+
qt_add_executable(contactlistexample WIN32 MACOSX_BUNDLE
contactmodel.cpp contactmodel.h
main.cpp
@@ -21,25 +16,33 @@ qt_add_executable(contactlistexample WIN32 MACOSX_BUNDLE
qt_add_qml_module(contactlistexample
URI contactlist
- NO_RESOURCE_TARGET_PATH
QML_FILES
"ContactDelegate.ui.qml"
"ContactDialog.qml"
"ContactForm.ui.qml"
"ContactView.ui.qml"
"SectionDelegate.ui.qml"
- "contactlist.qml"
+ "ContactList.qml"
"designer/Backend/ContactModel.qml"
)
target_link_libraries(contactlistexample PUBLIC
- Qt::Core
- Qt::Gui
- Qt::Quick
+ Qt6::Core
+ Qt6::Gui
+ Qt6::Quick
)
install(TARGETS contactlistexample
- RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
- BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
- LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"
+ BUNDLE DESTINATION .
+ RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR}
+ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
+)
+
+qt_generate_deploy_qml_app_script(
+ TARGET contactlistexample
+ OUTPUT_SCRIPT deploy_script
+ MACOS_BUNDLE_POST_BUILD
+ NO_UNSUPPORTED_PLATFORM_ERROR
+ DEPLOY_USER_QML_MODULES_ON_UNSUPPORTED_PLATFORM
)
+install(SCRIPT ${deploy_script})