aboutsummaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt38
1 files changed, 27 insertions, 11 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index a9948bc013..ca83200cf5 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -4,10 +4,11 @@
# Generated from src.pro.
# special case skip regeneration
-if (NOT QT_FEATURE_commandlineparser)
+if(NOT QT_FEATURE_commandlineparser)
message(FATAL_ERROR "QT_FEATURE_commandlineparser required to compile qmltyperegistrar")
endif()
+add_subdirectory(qmltoolingsettings)
add_subdirectory(qmltyperegistrar)
add_subdirectory(qmlintegration)
add_subdirectory(qml)
@@ -15,6 +16,10 @@ add_subdirectory(qmlmodels)
add_subdirectory(core)
+if(QT_FEATURE_qml_network)
+ add_subdirectory(qmlnetwork)
+endif()
+
if(QT_FEATURE_qml_worker_script)
add_subdirectory(qmlworkerscript)
endif()
@@ -23,7 +28,7 @@ if(TARGET Qt::Sql)
add_subdirectory(qmllocalstorage)
endif()
-if (QT_FEATURE_qml_xmllistmodel)
+if(QT_FEATURE_qml_xmllistmodel)
add_subdirectory(qmlxmllistmodel)
endif()
@@ -34,7 +39,7 @@ if(TARGET Qt::Gui AND TARGET Qt::qsb AND QT_FEATURE_qml_animation)
find_package(Qt6 ${PROJECT_VERSION} QUIET CONFIG OPTIONAL_COMPONENTS Test)
if(QT_FEATURE_testlib AND TARGET Qt::Test)
add_subdirectory(qmltest)
- if(QT_FEATURE_network)
+ if(QT_FEATURE_network AND QT_FEATURE_quick_itemview)
add_subdirectory(quicktestutils)
endif()
endif()
@@ -51,6 +56,10 @@ if(TARGET Qt::Gui AND TARGET Qt::qsb AND QT_FEATURE_qml_animation)
add_subdirectory(quickshapes)
endif()
+ if(TARGET Qt::Svg)
+ add_subdirectory(quickvectorimage)
+ endif()
+
if(TARGET Qt::Widgets)
add_subdirectory(quickwidgets)
endif()
@@ -58,10 +67,12 @@ if(TARGET Qt::Gui AND TARGET Qt::qsb AND QT_FEATURE_qml_animation)
add_subdirectory(quicktemplates)
add_subdirectory(quickcontrolsimpl)
add_subdirectory(quickcontrols)
- add_subdirectory(quickdialogs)
+ if(QT_FEATURE_quicktemplates2_container)
+ add_subdirectory(quickdialogs)
+ endif()
add_subdirectory(quicknativestyle)
- if(QT_FEATURE_testlib AND QT_FEATURE_network AND TARGET Qt::Test AND TARGET Qt::QuickControls2)
+ if(QT_FEATURE_testlib AND QT_FEATURE_network AND QT_FEATURE_quick_itemview AND TARGET Qt::Test AND TARGET Qt::QuickControls2 AND NOT (WASM AND BUILD_SHARED_LIBS))
add_subdirectory(quickcontrolstestutils)
endif()
else()
@@ -79,13 +90,18 @@ add_subdirectory(labs)
# These need to be included here since they have dependencies on the modules
# specified above.
-if(QT_FEATURE_qml_devtools)
- add_subdirectory(qmlcompiler)
- add_subdirectory(qmldom)
+add_subdirectory(qmlcompiler)
+add_subdirectory(qmldom)
+
+# Build qmlcachegen now, so that we can use it in src/imports.
+if(QT_FEATURE_xmlstreamwriter)
+ add_subdirectory(../tools/qmlcachegen qmlcachegen)
+endif()
- # Build qmlcachegen now, so that we can use it in src/imports.
- if(QT_FEATURE_qml_devtools AND QT_FEATURE_xmlstreamwriter)
- add_subdirectory(../tools/qmlcachegen qmlcachegen)
+if(QT_FEATURE_thread AND QT_FEATURE_filesystemwatcher AND QT_FEATURE_processenvironment
+ AND TARGET Qt::LanguageServerPrivate)
+ if (NOT CMAKE_CROSSCOMPILING OR QT_FORCE_BUILD_TOOLS)
+ add_subdirectory(qmlls)
endif()
endif()