aboutsummaryrefslogtreecommitdiffstats
path: root/src/core/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/core/CMakeLists.txt')
-rw-r--r--src/core/CMakeLists.txt39
1 files changed, 39 insertions, 0 deletions
diff --git a/src/core/CMakeLists.txt b/src/core/CMakeLists.txt
new file mode 100644
index 0000000000..1446f9844e
--- /dev/null
+++ b/src/core/CMakeLists.txt
@@ -0,0 +1,39 @@
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
+qt_internal_add_qml_module(QmlCore
+ URI "QtCore"
+ VERSION "${PROJECT_VERSION}"
+ DESIGNER_SUPPORTED
+ PLUGIN_TARGET qtqmlcoreplugin
+ CLASS_NAME QtQmlCorePlugin
+ DEPENDENCIES
+ QtQml/auto
+ SOURCES
+ qqmlsysteminformation_p.h
+ qqmlsysteminformation.cpp
+ qqmlstandardpaths_p.h
+ qqmlstandardpaths.cpp
+ qqmlcoreglobal_p.h
+ DEFINES
+ QT_BUILD_QML_CORE_LIB
+ PUBLIC_LIBRARIES
+ Qt::Core
+ Qt::Qml
+ GENERATE_CPP_EXPORTS
+ )
+
+qt_internal_extend_target(QmlCore CONDITION QT_FEATURE_settings
+ SOURCES
+ qqmlsettings_p.h
+ qqmlsettings.cpp
+)
+
+qt_internal_extend_target(QmlCore CONDITION QT_FEATURE_permissions
+ SOURCES
+ qqmlpermissions_p.h
+)
+
+qt_internal_add_docs(QmlCore
+ doc/qtqmlcore.qdocconf
+)