aboutsummaryrefslogtreecommitdiffstats
path: root/src/imports/core/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/imports/core/CMakeLists.txt')
-rw-r--r--src/imports/core/CMakeLists.txt17
1 files changed, 17 insertions, 0 deletions
diff --git a/src/imports/core/CMakeLists.txt b/src/imports/core/CMakeLists.txt
new file mode 100644
index 0000000000..6e4d54e066
--- /dev/null
+++ b/src/imports/core/CMakeLists.txt
@@ -0,0 +1,17 @@
+qt_internal_add_qml_module(qtqmlcoreplugin
+ URI "QtCore"
+ VERSION "${CMAKE_PROJECT_VERSION}"
+ DESIGNER_SUPPORTED
+ CLASS_NAME QtQmlCorePlugin
+ SKIP_TYPE_REGISTRATION
+ DEPENDENCIES
+ QtQml
+ PLUGIN_OPTIONAL
+ SOURCES
+ plugin.cpp
+ PUBLIC_LIBRARIES
+ Qt::Core
+ Qt::Qml
+ Qt::QmlCore
+ Qt::QmlCorePrivate
+)