aboutsummaryrefslogtreecommitdiffstats
path: root/src/imports/tooling/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/imports/tooling/CMakeLists.txt')
-rw-r--r--src/imports/tooling/CMakeLists.txt27
1 files changed, 27 insertions, 0 deletions
diff --git a/src/imports/tooling/CMakeLists.txt b/src/imports/tooling/CMakeLists.txt
new file mode 100644
index 0000000000..c58a2274e5
--- /dev/null
+++ b/src/imports/tooling/CMakeLists.txt
@@ -0,0 +1,27 @@
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
+set(qml_files
+ "Component.qml"
+ "Enum.qml"
+ "Member.qml"
+ "Method.qml"
+ "Module.qml"
+ "Parameter.qml"
+ "Property.qml"
+ "Signal.qml"
+)
+
+set_source_files_properties(${qml_files} PROPERTIES
+ QT_QML_SOURCE_VERSIONS "1.2;6.0"
+)
+
+qt_internal_add_qml_module(quicktooling
+ URI "QtQuick.tooling"
+ NO_SYNC_QT
+ VERSION "${PROJECT_VERSION}"
+ NO_PLUGIN_OPTIONAL
+ PLUGIN_TARGET quicktooling
+ PAST_MAJOR_VERSIONS 1
+ QML_FILES ${qml_files}
+)