aboutsummaryrefslogtreecommitdiffstats
path: root/src/labs/animation/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/labs/animation/CMakeLists.txt')
-rw-r--r--src/labs/animation/CMakeLists.txt19
1 files changed, 19 insertions, 0 deletions
diff --git a/src/labs/animation/CMakeLists.txt b/src/labs/animation/CMakeLists.txt
new file mode 100644
index 0000000000..bf8e41b7e2
--- /dev/null
+++ b/src/labs/animation/CMakeLists.txt
@@ -0,0 +1,19 @@
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
+qt_internal_add_qml_module(LabsAnimation
+ URI "Qt.labs.animation"
+ VERSION "${PROJECT_VERSION}"
+ PLUGIN_TARGET labsanimationplugin
+ CLASS_NAME QtLabsAnimationPlugin
+ DEPENDENCIES
+ QtQml
+ SOURCES
+ qquickboundaryrule.cpp qquickboundaryrule_p.h
+ qqmlanimationglobal_p.h
+ DEFINES
+ QT_BUILD_LABSANIMATION_LIB
+ PUBLIC_LIBRARIES
+ Qt::QmlPrivate
+ Qt::QuickPrivate
+ )