aboutsummaryrefslogtreecommitdiffstats
path: root/src/labs/models/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/labs/models/CMakeLists.txt')
-rw-r--r--src/labs/models/CMakeLists.txt29
1 files changed, 29 insertions, 0 deletions
diff --git a/src/labs/models/CMakeLists.txt b/src/labs/models/CMakeLists.txt
new file mode 100644
index 0000000000..0ae2d7d16e
--- /dev/null
+++ b/src/labs/models/CMakeLists.txt
@@ -0,0 +1,29 @@
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
+qt_internal_add_qml_module(LabsQmlModels
+ URI "Qt.labs.qmlmodels"
+ VERSION "${PROJECT_VERSION}"
+ PLUGIN_TARGET labsmodelsplugin
+ CLASS_NAME QtQmlLabsModelsPlugin
+ SOURCES
+ qqmlmodelsglobal_p.h
+ DEFINES
+ QT_BUILD_LABSQMLMODELS_LIB
+ PUBLIC_LIBRARIES
+ Qt::QmlModelsPrivate
+ Qt::QmlPrivate
+ DEPENDENCIES
+ QtQml.Models/auto
+ )
+
+qt_internal_extend_target(LabsQmlModels CONDITION QT_FEATURE_qml_table_model
+ SOURCES
+ qqmltablemodel.cpp qqmltablemodel_p.h
+ qqmltablemodelcolumn.cpp qqmltablemodelcolumn_p.h
+)
+
+qt_internal_extend_target(LabsQmlModels CONDITION QT_FEATURE_qml_delegate_model
+ SOURCES
+ qqmldelegatecomponent.cpp qqmldelegatecomponent_p.h
+)