aboutsummaryrefslogtreecommitdiffstats
path: root/src/labs/wavefrontmesh/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/labs/wavefrontmesh/CMakeLists.txt')
-rw-r--r--src/labs/wavefrontmesh/CMakeLists.txt20
1 files changed, 20 insertions, 0 deletions
diff --git a/src/labs/wavefrontmesh/CMakeLists.txt b/src/labs/wavefrontmesh/CMakeLists.txt
new file mode 100644
index 0000000000..5b0bdde643
--- /dev/null
+++ b/src/labs/wavefrontmesh/CMakeLists.txt
@@ -0,0 +1,20 @@
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
+qt_internal_add_qml_module(LabsWavefrontMesh
+ URI "Qt.labs.wavefrontmesh"
+ VERSION "${PROJECT_VERSION}"
+ PLUGIN_TARGET qmlwavefrontmeshplugin
+ CLASS_NAME QmlWavefrontMeshPlugin
+ DEPENDENCIES
+ QtQuick/auto
+ SOURCES
+ qwavefrontmesh.cpp qwavefrontmesh_p.h
+ qqmlwavefrontmeshglobal_p.h
+ DEFINES
+ QT_BUILD_LABSWAVEFRONTMESH_LIB
+ PUBLIC_LIBRARIES
+ Qt::CorePrivate
+ Qt::GuiPrivate
+ Qt::QuickPrivate
+ )