aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/qmltooling/qmldbg_server/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/plugins/qmltooling/qmldbg_server/CMakeLists.txt')
-rw-r--r--src/plugins/qmltooling/qmldbg_server/CMakeLists.txt23
1 files changed, 23 insertions, 0 deletions
diff --git a/src/plugins/qmltooling/qmldbg_server/CMakeLists.txt b/src/plugins/qmltooling/qmldbg_server/CMakeLists.txt
new file mode 100644
index 0000000000..a88a6f4f8f
--- /dev/null
+++ b/src/plugins/qmltooling/qmldbg_server/CMakeLists.txt
@@ -0,0 +1,23 @@
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
+# Generated from qmldbg_server.pro.
+
+#####################################################################
+## QQmlDebugServerFactory Plugin:
+#####################################################################
+
+qt_internal_add_plugin(QQmlDebugServerFactoryPlugin
+ OUTPUT_NAME qmldbg_server
+ CLASS_NAME QQmlDebugServerFactory
+ PLUGIN_TYPE qmltooling
+ SOURCES
+ qqmldebugserverfactory.cpp
+ qqmldebugserverfactory.h
+ LIBRARIES
+ Qt::PacketProtocolPrivate
+ Qt::QmlPrivate
+)
+
+#### Keys ignored in scope 1:.:.:qmldbg_server.pro:<TRUE>:
+# OTHER_FILES = "qqmldebugserver.json"