aboutsummaryrefslogtreecommitdiffstats
path: root/src/qmllocalstorage/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/qmllocalstorage/CMakeLists.txt')
-rw-r--r--src/qmllocalstorage/CMakeLists.txt18
1 files changed, 18 insertions, 0 deletions
diff --git a/src/qmllocalstorage/CMakeLists.txt b/src/qmllocalstorage/CMakeLists.txt
new file mode 100644
index 0000000000..0517b2231a
--- /dev/null
+++ b/src/qmllocalstorage/CMakeLists.txt
@@ -0,0 +1,18 @@
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
+qt_internal_add_qml_module(QmlLocalStorage
+ URI "QtQuick.LocalStorage"
+ VERSION "${PROJECT_VERSION}"
+ PLUGIN_TARGET qmllocalstorageplugin
+ CLASS_NAME QQmlLocalStoragePlugin
+ SOURCES
+ qqmllocalstorage.cpp qqmllocalstorage_p.h
+ qqmllocalstorageglobal_p.h
+ DEFINES
+ QT_BUILD_QMLLOCALSTORAGE_LIB
+ PUBLIC_LIBRARIES
+ Qt::CorePrivate
+ Qt::QmlPrivate
+ Qt::Sql
+ )