aboutsummaryrefslogtreecommitdiffstats
path: root/src/qmlxmllistmodel/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/qmlxmllistmodel/CMakeLists.txt')
-rw-r--r--src/qmlxmllistmodel/CMakeLists.txt28
1 files changed, 28 insertions, 0 deletions
diff --git a/src/qmlxmllistmodel/CMakeLists.txt b/src/qmlxmllistmodel/CMakeLists.txt
new file mode 100644
index 0000000000..5b56f6388b
--- /dev/null
+++ b/src/qmlxmllistmodel/CMakeLists.txt
@@ -0,0 +1,28 @@
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
+qt_internal_add_qml_module(QmlXmlListModel
+ URI "QtQml.XmlListModel"
+ VERSION "${PROJECT_VERSION}"
+ PLUGIN_TARGET qmlxmllistmodelplugin
+ CLASS_NAME QtQmlXmlListModelPlugin
+ DEPENDENCIES
+ QtQml/auto
+ SOURCES
+ qqmlxmllistmodel_p.h qqmlxmllistmodel.cpp
+ qtqmlxmllistmodelglobal_p.h
+ DEFINES
+ QT_BUILD_QMLXMLLISTMODEL_LIB
+ LIBRARIES
+ Qt::CorePrivate
+ Qt::QmlModelsPrivate
+ PUBLIC_LIBRARIES
+ Qt::Core
+ Qt::Qml
+ PRIVATE_MODULE_INTERFACE
+ Qt::CorePrivate
+ )
+
+qt_internal_add_docs(QmlXmlListModel
+ doc/qtqmlxmllistmodel.qdocconf
+)