aboutsummaryrefslogtreecommitdiffstats
path: root/src/quick/window/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/quick/window/CMakeLists.txt')
-rw-r--r--src/quick/window/CMakeLists.txt16
1 files changed, 16 insertions, 0 deletions
diff --git a/src/quick/window/CMakeLists.txt b/src/quick/window/CMakeLists.txt
new file mode 100644
index 0000000000..eb295449e4
--- /dev/null
+++ b/src/quick/window/CMakeLists.txt
@@ -0,0 +1,16 @@
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
+# This qml module only exists to satisfy backward compatibility.
+# The functionality was absorbed directly into QtQuick.
+
+qt_internal_add_qml_module(quickwindow
+ URI "QtQuick.Window"
+ VERSION "${PROJECT_VERSION}"
+ NO_PLUGIN_OPTIONAL
+ PLUGIN_TARGET quickwindow
+ CLASS_NAME QtQuick_WindowPlugin
+ IMPORTS
+ QtQuick/auto
+ PAST_MAJOR_VERSIONS 2
+)