aboutsummaryrefslogtreecommitdiffstats
path: root/src/quickcontrols/macos/impl/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/quickcontrols/macos/impl/CMakeLists.txt')
-rw-r--r--src/quickcontrols/macos/impl/CMakeLists.txt22
1 files changed, 22 insertions, 0 deletions
diff --git a/src/quickcontrols/macos/impl/CMakeLists.txt b/src/quickcontrols/macos/impl/CMakeLists.txt
new file mode 100644
index 0000000000..6d007f4d9f
--- /dev/null
+++ b/src/quickcontrols/macos/impl/CMakeLists.txt
@@ -0,0 +1,22 @@
+# Copyright (C) 2023 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
+set(qml_files
+ "SwitchHandle.qml"
+ "SwitchIndicator.qml"
+)
+
+qt_internal_add_qml_module(QuickControls2MacOSStyleImpl
+ URI "QtQuick.Controls.macOS.impl"
+ VERSION "${PROJECT_VERSION}"
+ PAST_MAJOR_VERSIONS 6
+ CLASS_NAME QtQuickControls2macOSStyleImplPlugin
+ DEPENDENCIES
+ QtQuick/auto
+ PLUGIN_TARGET qtquickcontrols2macosstyleimplplugin
+ QML_FILES
+ ${qml_files}
+ DEFINES
+ QT_NO_CAST_FROM_ASCII
+ QT_NO_CAST_TO_ASCII
+)