aboutsummaryrefslogtreecommitdiffstats
path: root/src/quickcontrols/windows/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/quickcontrols/windows/CMakeLists.txt')
-rw-r--r--src/quickcontrols/windows/CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/src/quickcontrols/windows/CMakeLists.txt b/src/quickcontrols/windows/CMakeLists.txt
index b5319fef52..55c57a956c 100644
--- a/src/quickcontrols/windows/CMakeLists.txt
+++ b/src/quickcontrols/windows/CMakeLists.txt
@@ -6,16 +6,24 @@
#####################################################################
set(qml_files
+ "ApplicationWindow.qml"
"Button.qml"
"CheckBox.qml"
+ "CheckDelegate.qml"
"ComboBox.qml"
+ "DelayButton.qml"
"Frame.qml"
"GroupBox.qml"
+ "ItemDelegate.qml"
"ProgressBar.qml"
"RadioButton.qml"
+ "RadioDelegate.qml"
+ "RangeSlider.qml"
"SelectionRectangle.qml"
"Slider.qml"
"SpinBox.qml"
+ "Switch.qml"
+ "SwitchDelegate.qml"
"TextArea.qml"
"TextField.qml"
"ScrollBar.qml"
@@ -44,10 +52,13 @@ qt_internal_add_qml_module(qtquickcontrols2windowsstyleplugin
Qt::GuiPrivate
Qt::QmlPrivate
Qt::QuickControls2Private
+ Qt::QuickControls2WindowsStyleImpl
Qt::QuickPrivate
Qt::QuickTemplates2Private
)
+add_subdirectory(impl)
+
# Native style is a dependency of the Windows style.
_qt_internal_add_qml_static_plugin_dependency(qtquickcontrols2windowsstyleplugin
qtquickcontrols2nativestyleplugin)