aboutsummaryrefslogtreecommitdiffstats
path: root/tests/auto/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/CMakeLists.txt')
-rw-r--r--tests/auto/CMakeLists.txt51
1 files changed, 38 insertions, 13 deletions
diff --git a/tests/auto/CMakeLists.txt b/tests/auto/CMakeLists.txt
index 2ff1f198f0..b47bd318d5 100644
--- a/tests/auto/CMakeLists.txt
+++ b/tests/auto/CMakeLists.txt
@@ -1,23 +1,48 @@
-# Generated from auto.pro.
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
-add_subdirectory(qml)
-add_subdirectory(quick)
-add_subdirectory(quicktest)
-add_subdirectory(qmldevtools)
-# special case begin
-# add_subdirectory(cmake)
-# add_subdirectory(installed_cmake)
-# special case end
+add_subdirectory(cmake)
+
+# For now, only build a subset of CMake auto tests when QT_BUILD_MINIMAL_STATIC_TEST
+# is specified and the build is targeting iOS. QT_BUILD_MINIMAL_STATIC_TEST is used in our CI.
+# Regular tests shouldn't be built because the CI will try to run them and fail due to missing
+# simulator support.
+if(IOS AND QT_BUILD_MINIMAL_STATIC_TESTS)
+ return()
+endif()
+
+if(TARGET Qt::Quick)
+ add_subdirectory(qml)
+ add_subdirectory(quick)
+endif()
+
+# Limit set of tests to run for static Qt builds.
+if(QT_BUILD_MINIMAL_STATIC_TESTS)
+ return()
+endif()
+
+if(TARGET Qt::Quick)
+ add_subdirectory(quicktest)
+endif()
+if(TARGET Qt::QuickTest)
+ add_subdirectory(core)
+ add_subdirectory(qmlnetwork)
+endif()
add_subdirectory(toolsupport)
-if(NOT UIKIT)
+if(NOT UIKIT AND NOT ANDROID AND NOT QNX) # FIXME: QTBUG-92591 QTBUG-100202
add_subdirectory(qmltest)
endif()
-if(TARGET Qt::Gui)
+if(TARGET Qt::Quick)
add_subdirectory(particles)
endif()
-if(TARGET Qt::Widgets)
+if(TARGET Qt::QuickWidgets)
add_subdirectory(quickwidgets)
endif()
-if(TARGET Qt::QmlDom)
+if(TARGET Qt::QmlDomPrivate AND NOT CMAKE_CROSSCOMPILING)
add_subdirectory(qmldom)
+ add_subdirectory(qmlls)
+endif()
+if(TARGET Qt::QuickTemplates2)
+ add_subdirectory(quickcontrols)
+ add_subdirectory(quickdialogs)
endif()