aboutsummaryrefslogtreecommitdiffstats
path: root/tests/auto/qml/debugger/qqmldebugprocess/qqmldebugprocess/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/qml/debugger/qqmldebugprocess/qqmldebugprocess/CMakeLists.txt')
-rw-r--r--tests/auto/qml/debugger/qqmldebugprocess/qqmldebugprocess/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/tests/auto/qml/debugger/qqmldebugprocess/qqmldebugprocess/CMakeLists.txt b/tests/auto/qml/debugger/qqmldebugprocess/qqmldebugprocess/CMakeLists.txt
index ea07333ec7..54fe36b7d5 100644
--- a/tests/auto/qml/debugger/qqmldebugprocess/qqmldebugprocess/CMakeLists.txt
+++ b/tests/auto/qml/debugger/qqmldebugprocess/qqmldebugprocess/CMakeLists.txt
@@ -7,6 +7,12 @@
## tst_qqmldebugprocess Test:
#####################################################################
+if(NOT QT_BUILD_STANDALONE_TESTS AND NOT QT_BUILDING_QT)
+ cmake_minimum_required(VERSION 3.16)
+ project(tst_qqmldebugprocess LANGUAGES CXX)
+ find_package(Qt6BuildInternals REQUIRED COMPONENTS STANDALONE_TEST)
+endif()
+
qt_internal_add_test(tst_qqmldebugprocess
SOURCES
../../shared/qqmldebugprocess.cpp ../../shared/qqmldebugprocess_p.h