aboutsummaryrefslogtreecommitdiffstats
path: root/tests/auto/qml/debugger/qqmlenginedebugservice/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/qml/debugger/qqmlenginedebugservice/CMakeLists.txt')
-rw-r--r--tests/auto/qml/debugger/qqmlenginedebugservice/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/tests/auto/qml/debugger/qqmlenginedebugservice/CMakeLists.txt b/tests/auto/qml/debugger/qqmlenginedebugservice/CMakeLists.txt
index 9afe16c4ad..e632f91548 100644
--- a/tests/auto/qml/debugger/qqmlenginedebugservice/CMakeLists.txt
+++ b/tests/auto/qml/debugger/qqmlenginedebugservice/CMakeLists.txt
@@ -4,6 +4,12 @@
## tst_qqmlenginedebugservice Test:
#####################################################################
+# Collect test data
+file(GLOB_RECURSE test_data_glob
+ RELATIVE ${CMAKE_CURRENT_SOURCE_DIR}
+ data/*)
+list(APPEND test_data ${test_data_glob})
+
qt_internal_add_test(tst_qqmlenginedebugservice
SOURCES
../shared/debugutil.cpp ../shared/debugutil_p.h
@@ -19,6 +25,7 @@ qt_internal_add_test(tst_qqmlenginedebugservice
Qt::QmlPrivate
Qt::Quick
Qt::QuickTestUtilsPrivate
+ TESTDATA ${test_data}
)
## Scopes: