aboutsummaryrefslogtreecommitdiffstats
path: root/tests/auto/qml/qml/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/qml/qml/CMakeLists.txt')
-rw-r--r--tests/auto/qml/qml/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/tests/auto/qml/qml/CMakeLists.txt b/tests/auto/qml/qml/CMakeLists.txt
index a696d80c4d..39056384de 100644
--- a/tests/auto/qml/qml/CMakeLists.txt
+++ b/tests/auto/qml/qml/CMakeLists.txt
@@ -1,6 +1,12 @@
# Copyright (C) 2023 The Qt Company Ltd.
# SPDX-License-Identifier: BSD-3-Clause
+if(NOT QT_BUILD_STANDALONE_TESTS AND NOT QT_BUILDING_QT)
+ cmake_minimum_required(VERSION 3.16)
+ project(tst_qml LANGUAGES CXX)
+ find_package(Qt6BuildInternals REQUIRED COMPONENTS STANDALONE_TEST)
+endif()
+
# Collect test data
file(GLOB_RECURSE test_data_glob
RELATIVE ${CMAKE_CURRENT_SOURCE_DIR}
@@ -15,4 +21,6 @@ qt_internal_add_test(tst_qml
QT_QMLTEST_DATADIR="${CMAKE_CURRENT_SOURCE_DIR}/data"
LIBRARIES
Qt::QuickTestUtilsPrivate
+ Qt::Gui
+ Qt::GuiPrivate
)